Back to overview
Resolved

NBN, NBN Enterprise Disruption – 12-06-2026

Jun 12, 2026 at 1:02am UTC
Affected services
NBN Services - Standard Business
Enterprise Ethernet (NBN-EE) - Queensland
Enterprise Ethernet (NBN-EE) - NSW & VIC

Resolved
Jun 12, 2026 at 2:29am UTC

Service issues impacting some customers on NBN, NBN Enterprise & TPG have been resolved by the carrier - and services should now return to normal.

Created
Jun 12, 2026 at 1:02am UTC

Our Providers are currently investigating an issue affecting some NBN Internet, NBN Enterprise Services. Customers may experience dropouts, or service time outs while this is being investigated and resolved.